Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2020-36428: Debian libmatio may allow memory overwrite
CVE-2020-36428 · published 5 years ago
Summary
The libmatio library used in Debian versions 1.5.18 to 1.5.21 can be tricked into writing data beyond its allocated memory. This could let an attacker cause the program to crash or potentially run unwanted code. Update libmatio to a newer version or apply the vendor’s patch to fix the issue.
What to do
- Update debian libmatio to version 1.5.22-1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Debian:12 | debian | libmatio |
< 1.5.22-1 Fix: upgrade to 1.5.22-1
|
| Debian:13 | debian | libmatio |
< 1.5.22-1 Fix: upgrade to 1.5.22-1
|
| Debian:14 | debian | libmatio |
< 1.5.22-1 Fix: upgrade to 1.5.22-1
|
| – | matio_project | matio |
>= 1.5.18, <= 1.5.21 cpe:2.3:a:matio_project:matio:*:*:*:*:*:*:*:* |
Original advisory text
matio (aka MAT File I/O Library) 1.5.18 through 1.5.21 has a heap-based buffer overflow in ReadInt32DataDouble (called from ReadInt32Data and Mat_VarRead4).
matio (aka MAT File I/O Library) 1.5.18 through 1.5.21 has a heap-based buffer overflow in ReadInt32DataDouble (called from ReadInt32Data and Mat_VarRead4).
References
- https://security-tracker.debian.org/tracker/CVE-2020-36428 Vendor Advisory
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=21421 Third Party Advisory
- https://github.com/google/oss-fuzz-vulns/blob/main/vulns/matio/OSV-2020-799.yaml Third Party Advisory
Severity
8.8
High
Type
CWE-787Out-of-bounds Write
Timeline
Published20 Jul 2021
Updated4 Nov 2026
First seen11 Sep 2026
Track software like this
Free during beta