Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.0

CVE-2020-35936: Stored Cross-Site Scripting (XSS) vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remo...

CVE-2020-35936 · published 5 years ago
Summary

Stored Cross-Site Scripting (XSS) vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remotely hosted crafted payload in the source parameter via AJAX. The action must be set to post_grid_impor...

What to do
  • Update pickplugins post_grid to version 2.0.73 or later.
  • Update pickplugins team_showcase to version 1.22.16 or later.
Affected software
VendorProductAffected versions
pickplugins post_grid < 2.0.73
cpe:2.3:a:pickplugins:post_grid:*:*:*:*:*:wordpress:*:*
pickplugins team_showcase < 1.22.16
cpe:2.3:a:pickplugins:team_showcase:*:*:*:*:*:wordpress:*:*
Original advisory text
Stored Cross-Site Scripting (XSS) vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remo...
Stored Cross-Site Scripting (XSS) vulnerabilities in the Post Grid plugin before 2.0.73 for WordPress allow remote authenticated attackers to import layouts including JavaScript supplied via a remotely hosted crafted payload in the source parameter via AJAX. The action must be set to post_grid_import_xml_layouts.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
8.0 High
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published1 Jan 2021
Updated3 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta