Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2020-25706: Cacti template import can run malicious code

CVE-2020-25706 · published 5 years ago
Summary

The Cacti monitoring tool (version 1.2.13) does not properly clean up error messages when previewing a template import. An attacker could insert harmful script code that runs in a user's browser, potentially stealing data or changing settings. Update Cacti to the latest version or apply the provided patch to fix the input handling.

What to do
  • Update debian cacti to version 1.2.14+ds1-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian cacti < 1.2.14+ds1-1
Fix: upgrade to 1.2.14+ds1-1
Debian:13 debian cacti < 1.2.14+ds1-1
Fix: upgrade to 1.2.14+ds1-1
Debian:14 debian cacti < 1.2.14+ds1-1
Fix: upgrade to 1.2.14+ds1-1
– cacti cacti 1.2.13
cpe:2.3:a:cacti:cacti:1.2.13:*:*:*:*:*:*:*
– debian debian_linux 10.0
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
Original advisory text
A cross-site scripting (XSS) vulnerability exists in templates_import.php (Cacti 1.2.13) due to Improper escaping of error message during template import preview in the xml_path field
A cross-site scripting (XSS) vulnerability exists in templates_import.php (Cacti 1.2.13) due to Improper escaping of error message during template import preview in the xml_path field
Severity
6.1 Medium
Exploitation
3% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Nov 2020
Updated30 Oct 2026
First seen11 Sep 2026
Sources
CVE-2020-25706 · NVD
Track software like this
Free during beta