Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.3

CVE-2020-17380: QEMU up to 5.0.0 allows host crash or code execution

CVE-2020-17380 · published 5 years ago
Summary

The QEMU virtual machine software (versions up through 5.0.0) has a flaw in its emulated SD card controller that can be triggered during certain data transfers. An attacker inside a guest VM could cause the QEMU program on the host to stop working or run malicious code with the same rights as the QEMU process. Update to a fixed QEMU release or apply the vendor's patch to prevent the issue.

What to do
  • Update debian qemu to version 1:5.2+dfsg-10.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian qemu < 1:5.2+dfsg-10
Fix: upgrade to 1:5.2+dfsg-10
Debian:13 debian qemu < 1:5.2+dfsg-10
Fix: upgrade to 1:5.2+dfsg-10
Debian:14 debian qemu < 1:5.2+dfsg-10
Fix: upgrade to 1:5.2+dfsg-10
– qemu qemu <= 5.0.0
cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:*
– debian debian_linux 9.0
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
Original advisory text
A heap-based buffer overflow was found in QEMU through 5.0.0 in the SDHCI device emulation support. It could occur while doing a multi block SDMA transfer via the sdhci_sdma_transfer_multi_blocks()...
A heap-based buffer overflow was found in QEMU through 5.0.0 in the SDHCI device emulation support. It could occur while doing a multi block SDMA transfer via the sdhci_sdma_transfer_multi_blocks() routine in hw/sd/sdhci.c. A guest user or process could use this flaw to crash the QEMU process on the host, resulting in a denial of service condition, or potentially execute arbitrary code with privileges of the QEMU process on the host.
Severity
6.3 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-787Out-of-bounds Write
Timeline
Published30 Jan 2021
Updated4 Nov 2026
First seen11 Sep 2026
Sources
CVE-2020-17380 · NVD
Track software like this
Free during beta