Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.1
CVE-2020-15156: NodeBB Blog Comments Plugin Allows Unapproved Posts by Attacker
CVE-2020-15156 · published 6 years ago
Summary
A security issue in NodeBB's blog comments plugin lets a malicious user post on someone else's behalf on a forum. This could lead to spam or malicious content. Update the plugin to version 0.7.0 or later to fix this issue.
What to do
- Update baris nodebb-plugin-blog-comments to version 0.7.0.
- Update nodebb blog_comments to version 0.7.0 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| npm | baris | nodebb-plugin-blog-comments |
< 0.7.0 Fix: upgrade to 0.7.0
|
| – | nodebb | blog_comments |
< 0.7.0 cpe:2.3:a:nodebb:blog_comments:*:*:*:*:*:node.js:*:* |
Original advisory text
In nodebb-plugin-blog-comments before version 0.7.0, a logged in user is vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. This is due to lack of CSR...
In nodebb-plugin-blog-comments before version 0.7.0, a logged in user is vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. This is due to lack of CSRF validation.
References
- https://github.com/psychobunny/nodebb-plugin-blog-comments/security/advisories/G...
- https://github.com/psychobunny/nodebb-plugin-blog-comments/commit/cf43beedb05131...
- https://nvd.nist.gov/vuln/detail/CVE-2020-15156
- https://www.npmjs.com/package/nodebb-plugin-blog-comments
- https://github.com/advisories/GHSA-43m5-c88r-cjvv
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Severity
8.1
High
Type
CWE-352Cross-Site Request Forgery (CSRF)
Timeline
Published26 Aug 2020
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta