Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2020-12462: The ninja-forms plugin before 3.4.24.2 for WordPress allows CSRF with resultant XSS.
CVE-2020-12462 · published 6 years ago
Summary
The ninja-forms plugin before 3.4.24.2 for WordPress allows CSRF with resultant XSS.
What to do
- Update ninjaforms ninja_forms to version 3.4.24.2 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| ninjaforms | ninja_forms |
< 3.4.24.2 cpe:2.3:a:ninjaforms:ninja_forms:*:*:*:*:*:wordpress:*:* |
Original advisory text
The ninja-forms plugin before 3.4.24.2 for WordPress allows CSRF with resultant XSS.
The ninja-forms plugin before 3.4.24.2 for WordPress allows CSRF with resultant XSS.
References
- https://wordpress.org/plugins/ninja-forms/#developers Release Notes Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-352Cross-Site Request Forgery (CSRF)
Timeline
Published29 Apr 2020
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2020-12462 · NVD
Track software like this
Free during beta