Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2019-9010: CODESYS Gateway may accept unauthorized connections

CVE-2019-9010 · published 7 years ago
Summary

The CODESYS Gateway in several CODESYS Control products does not properly check who is using a communication channel, allowing an attacker to connect as if they were a trusted device. This could let intruders send commands or view data from your automation system. Update all affected CODESYS products to version 3.5.14.20 or later, or apply the vendor's patch, to restore proper verification.

What to do
  • Update codesys control_for_beaglebone_sl to version 3.5.14.20 or later.
  • Update codesys control_for_empc-a\/imx6_sl to version 3.5.14.20 or later.
  • Update codesys control_for_iot2000_sl to version 3.5.14.20 or later.
  • Update codesys control_for_linux_sl to version 3.5.14.20 or later.
  • Update codesys control_for_pfc100_sl to version 3.5.14.20 or later.
  • Update codesys control_for_pfc200_sl to version 3.5.14.20 or later.
  • Update codesys control_for_raspberry_pi_sl to version 3.5.14.20 or later.
  • Update codesys control_runtime_toolkit to version 3.5.14.20 or later.
  • Update codesys development_system to version 3.5.14.20 or later.
  • Update codesys gateway to version 3.5.14.20 or later.
Affected software
VendorProductAffected versions
codesys control_for_beaglebone_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_beaglebone_sl:*:*:*:*:*:*:*:*
codesys control_for_empc-a\/imx6_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_empc-a\/imx6_sl:*:*:*:*:*:*:*:*
codesys control_for_iot2000_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_iot2000_sl:*:*:*:*:*:*:*:*
codesys control_for_linux_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_linux_sl:*:*:*:*:*:*:*:*
codesys control_for_pfc100_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_pfc100_sl:*:*:*:*:*:*:*:*
codesys control_for_pfc200_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_pfc200_sl:*:*:*:*:*:*:*:*
codesys control_for_raspberry_pi_sl >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_for_raspberry_pi_sl:*:*:*:*:*:*:*:*
codesys control_runtime_toolkit >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:control_runtime_toolkit:*:*:*:*:*:*:*:*
codesys development_system >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:development_system:*:*:*:*:*:*:*:*
codesys gateway >= 3.0, < 3.5.14.20
cpe:2.3:a:codesys:gateway:*:*:*:*:*:*:*:*
Original advisory text
An issue was discovered in 3S-Smart CODESYS V3 products. The CODESYS Gateway does not correctly verify the ownership of a communication channel. All variants of the following CODESYS V3 products in...
An issue was discovered in 3S-Smart CODESYS V3 products. The CODESYS Gateway does not correctly verify the ownership of a communication channel. All variants of the following CODESYS V3 products in all versions prior to v3.5.14.20 that contain the CmpGateway component are affected, regardless of the CPU type or operating system: CODESYS Control for BeagleBone, CODESYS Control for emPC-A/iMX6, CODESYS Control for IOT2000, CODESYS Control for Linux, CODESYS Control for PFC100, CODESYS Control for PFC200, CODESYS Control for Raspberry Pi, CODESYS Control V3 Runtime System Toolkit, CODESYS Gateway V3, CODESYS V3 Development System.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
2% chance of attack within 30 days
Timeline
Published15 Aug 2019
Updated2 Nov 2026
First seen29 Sep 2026
Sources
CVE-2019-9010 · NVD
Track software like this
Free during beta