Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2019-8145: Arbitrary JavaScript code can be injected into Magento product listings
CVE-2019-8145 · published 7 years ago
Summary
An authenticated user in Magento 2.2.9 or earlier, and Magento 2.3.2 or earlier, can inject malicious JavaScript code into product listings, which could allow them to steal sensitive user data or take control of the site. This affects sites that use these versions of Magento. To protect your site, update to the latest version of Magento.
What to do
- Update magento community-edition to version 2.2.10.
- Update magento community-edition to version 2.3.2-p1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| composer | magento | community-edition |
>= 2.2, < 2.2.10 >= 2.3, < 2.3.2-p1 Fix: upgrade to 2.2.10
|
| – | magento | magento |
>= 2.2.0, < 2.2.10 >= 2.3.0, < 2.3.2 2.3.2 cpe:2.3:a:magento:magento:*:*:*:*:commerce:*:*:* |
Original advisory text
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code into the ...
A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code into the attribute set name when listing the products.
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published6 Nov 2019
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta