Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.8

CVE-2019-7897: Magento Admin Panel Allows Malicious Code Injection

CVE-2019-7897 · published 7 years ago
Summary

A security flaw in Magento's admin panel allows an authorized user to inject malicious JavaScript. This could lead to unauthorized changes or data theft. Update to the latest version of Magento to fix the issue.

What to do
  • Update magento community-edition to version 2.1.18.
  • Update magento community-edition to version 2.2.9.
  • Update magento community-edition to version 2.3.2.
Affected software
Ecosystem VendorProductAffected versions
composer magento community-edition >= 2.1.0, < 2.1.18
>= 2.2.0, < 2.2.9
>= 2.3.0, < 2.3.2
Fix: upgrade to 2.1.18
– magento magento < 1.9.4.2
< 1.14.4.2
>= 2.1.0, < 2.1.18
>= 2.2.0, < 2.2.9
>= 2.3.0, < 2.3.2
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*
Original advisory text
A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior...
A stored cross-site scripting vulnerability exists in the admin panel of Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This could be exploited by an authenticated user with privileges to customer configurations to inject malicious javascript.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.8 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published2 Aug 2019
Updated4 Nov 2026
First seen6 Mar 2026
Sources
CVE-2019-7897 · NVD
CVE-2019-7897 · OSV
Track software like this
Free during beta