Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.5

CVE-2019-7888: Magento Leaks Sensitive Data via Malicious Email Templates

CVE-2019-7888 · published 7 years ago
Summary

Magento versions 2.1 through 2.3 have a security issue that allows a user with special permissions to access sensitive information by creating a malicious email template. This could lead to unauthorized access to confidential details. To fix this, update Magento to version 2.1.18 or later, 2.2.9 or later, or 2.3.2 or later.

What to do
  • Update magento community-edition to version 2.1.18.
  • Update magento community-edition to version 2.2.9.
  • Update magento community-edition to version 2.3.2.
Affected software
Ecosystem VendorProductAffected versions
composer magento community-edition >= 2.1, < 2.1.18
>= 2.2, < 2.2.9
>= 2.3, < 2.3.2
Fix: upgrade to 2.1.18
– magento magento >= 2.1.0, < 2.1.18
>= 2.2.0, < 2.2.9
>= 2.3.0, < 2.3.2
cpe:2.3:a:magento:magento:*:*:*:*:open_source:*:*:*
Original advisory text
An information disclosure vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to create email template...
An information disclosure vulnerability exists in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to create email templates could leak sensitive data via a malicious email template.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.5 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-200Information Exposure
Timeline
Published2 Aug 2019
Updated3 Nov 2026
First seen6 Mar 2026
Sources
CVE-2019-7888 · NVD
CVE-2019-7888 · OSV
Track software like this
Free during beta