Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2019-7740: Joomla! before 3.9.3 permits hidden code injection
CVE-2019-7740 · published 7 years ago
Summary
Versions of Joomla! older than 3.9.3 contain a flaw in a JavaScript file that can let an attacker insert malicious code into web pages viewed by users. This could let the attacker steal information or manipulate what the user sees. Upgrade Joomla! to version 3.9.3 or newer to close the risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| joomla | joomla\! |
>= 2.5.0, <= 3.9.2 cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in Joomla! before 3.9.3. Inadequate parameter handling in JavaScript code (core.js writeDynaList) could lead to an XSS attack vector.
An issue was discovered in Joomla! before 3.9.3. Inadequate parameter handling in JavaScript code (core.js writeDynaList) could lead to an XSS attack vector.
References
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Feb 2019
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2019-7740 · NVD
Track software like this
Free during beta