Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.3

CVE-2019-20921: Bootstrap-Select: Unescaped OPTION Elements Allow Browser Attacks

CVE-2019-20921 · published 6 years ago
Summary

A security issue in Bootstrap-Select could allow hackers to trick users into executing malicious code in their browser. This is due to not properly escaping certain text in dropdown menus. Update to version 1.13.6 or later to protect your site.

What to do
  • Update caseyjhol bootstrap-select to version 1.13.6.
  • Update casey holzer bootstrap-select to version 1.13.6.
  • Update snapappointments bootstrap-select to version 1.13.6 or later.
Affected software
Ecosystem VendorProductAffected versions
npm caseyjhol bootstrap-select < 1.13.6
Fix: upgrade to 1.13.6
nuget casey holzer bootstrap-select < 1.13.6
Fix: upgrade to 1.13.6
– snapappointments bootstrap-select < 1.13.6
cpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:node.js:*:*
Original advisory text
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.3 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published30 Sep 2020
Updated3 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta