Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2019-19578: Xen can crash when a guest creates bad page tables
CVE-2019-19578 · published 6 years ago
Summary
All versions of the Xen hypervisor on x86 computers are affected. A specially crafted or faulty virtual machine can build malformed page tables that cause the host to crash, leading to a denial of service and possible security risks. Update Xen to the latest release that includes the corrected handling of these page tables.
What to do
- Update alpine xen to version 4.12.2-r0.
- Update alpine xen to version 4.13.0-r0.
- Update alpine xen to version 4.10.4-r2.
- Update alpine xen to version 4.11.3-r1.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Alpine:v3.10 | alpine | xen |
< 4.12.2-r0 Fix: upgrade to 4.12.2-r0
|
| Alpine:v3.11 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.12 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.13 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.14 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.15 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.16 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.17 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.18 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.19 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.20 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.21 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.22 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.23 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.24 | alpine | xen |
< 4.13.0-r0 Fix: upgrade to 4.13.0-r0
|
| Alpine:v3.8 | alpine | xen |
< 4.10.4-r2 Fix: upgrade to 4.10.4-r2
|
| Alpine:v3.9 | alpine | xen |
< 4.11.3-r1 Fix: upgrade to 4.11.3-r1
|
| – | xen | xen |
<= 4.12.1 cpe:2.3:o:xen:xen:*:*:*:*:*:*:x86:* |
| – | fedoraproject | fedora |
31 cpe:2.3:o:fedoraproject:fedora:31:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in Xen through 4.12.x allowing x86 PV guest OS users to cause a denial of service via degenerate chains of linear pagetables, because of an incorrect fix for CVE-2017-15595....
An issue was discovered in Xen through 4.12.x allowing x86 PV guest OS users to cause a denial of service via degenerate chains of linear pagetables, because of an incorrect fix for CVE-2017-15595. "Linear pagetables" is a technique which involves either pointing a pagetable at itself, or to another pagetable of the same or higher level. Xen has limited support for linear pagetables: A page may either point to itself, or point to another pagetable of the same level (i.e., L2 to L2, L3 to L3, and so on). XSA-240 introduced an additional restriction that limited the "depth" of such chains by allowing pages to either *point to* other pages of the same level, or *be pointed to* by other pages of the same level, but not both. To implement this, we keep track of the number of outstanding times a page points to or is pointed to another page table, to prevent both from happening at the same time. Unfortunately, the original commit introducing this reset this count when resuming validation of a partially-validated pagetable, incorrectly dropping some "linear_pt_entry" counts. If an attacker could engineer such a situation to occur, they might be able to make loops or other arbitrary chains of linear pagetables, as described in XSA-240. A malicious or buggy PV guest may cause the hypervisor to crash, resulting in Denial of Service (DoS) affecting the entire host. Privilege escalation and information leaks cannot be excluded. All versions of Xen are vulnerable. Only x86 systems are affected. Arm systems are not affected. Only x86 PV guests can leverage the vulnerability. x86 HVM and PVH guests cannot leverage the vulnerability. Only systems which have enabled linear pagetables are vulnerable. Systems which have disabled linear pagetables, either by selecting CONFIG_PV_LINEAR_PT=n when building the hypervisor, or adding pv-linear-pt=false on the command-line, are not vulnerable.
References
- https://security.alpinelinux.org/vuln/CVE-2019-19578 Vendor Advisory
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00011.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro...
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro...
- https://seclists.org/bugtraq/2020/Jan/21
- https://security.gentoo.org/glsa/202003-56
- https://www.debian.org/security/2020/dsa-4602
- https://xenbits.xen.org/xsa/advisory-309.html Patch Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-682Incorrect Calculation
Timeline
Published11 Dec 2019
Updated4 Nov 2026
First seen10 Sep 2026
Track software like this
Free during beta