Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2019-19284: A vulnerability has been identified in XHQ (All Versions < 6.1). The web interface could allow Cross-Site Scripting (XSS) attacks if an attacker is able to modify content of particular web pages, c...
CVE-2019-19284 · published 5 years ago
Summary
A vulnerability has been identified in XHQ (All Versions < 6.1). The web interface could allow Cross-Site Scripting (XSS) attacks if an attacker is able to modify content of particular web pages, causing the application to behave in unexpected ways for legitimate users.
What to do
- Update siemens xhq to version 6.1.0.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| siemens | xhq |
< 6.1.0.0 cpe:2.3:a:siemens:xhq:*:*:*:*:*:*:*:* |
Original advisory text
A vulnerability has been identified in XHQ (All Versions < 6.1). The web interface could allow Cross-Site Scripting (XSS) attacks if an attacker is able to modify content of particular web pages, c...
A vulnerability has been identified in XHQ (All Versions < 6.1). The web interface could allow Cross-Site Scripting (XSS) attacks if an attacker is able to modify content of particular web pages, causing the application to behave in unexpected ways for legitimate users.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-712690.pdf Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published14 Dec 2020
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2019-19284 · NVD
Track software like this
Free during beta