Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.8

CVE-2019-19261: GitLab EE lets attackers trick it into internal requests

CVE-2019-19261 · published 6 years ago
Summary

Versions of GitLab Enterprise Edition from 6.7 up to 12.5 can be made to send network requests to internal systems that should not be reachable. This could let a remote user discover or interact with services behind your firewall. Upgrade to a newer GitLab release or apply the vendor's patch as soon as possible.

What to do
  • Update gitlab gitlab to version 12.5.1 or later.
Affected software
VendorProductAffected versions
gitlab gitlab >= 6.7.0, < 12.5.1
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
Original advisory text
GitLab Enterprise Edition (EE) 6.7 and later through 12.5 allows SSRF.
GitLab Enterprise Edition (EE) 6.7 and later through 12.5 allows SSRF.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
8.8 High
Exploitation
1% chance of attack within 30 days
Type
CWE-918Server-Side Request Forgery (SSRF)
Timeline
Published3 Jan 2020
Updated31 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta