Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.9

CVE-2019-19080: Linux kernel before 5.3.4 can exhaust memory

CVE-2019-19080 · published 6 years ago
Summary

The Linux kernel version earlier than 5.3.4 has a coding error that can leak memory when handling certain network traffic. Over time this can use up all available memory and cause the system to stop responding. Update the kernel to version 5.3.4 or later, or apply the supplied security patches, to prevent the issue.

What to do
  • Update debian linux to version 5.3.7-1.
  • Update linux linux_kernel to version 5.3.4 or later.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian linux < 5.3.7-1
Fix: upgrade to 5.3.7-1
Debian:13 debian linux < 5.3.7-1
Fix: upgrade to 5.3.7-1
Debian:14 debian linux < 5.3.7-1
Fix: upgrade to 5.3.7-1
– linux linux_kernel < 5.3.4
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
– opensuse leap 15.1
cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:*
Original advisory text
Four memory leaks in the nfp_flower_spawn_phy_reprs() function in drivers/net/ethernet/netronome/nfp/flower/main.c in the Linux kernel before 5.3.4 allow attackers to cause a denial of service (mem...
Four memory leaks in the nfp_flower_spawn_phy_reprs() function in drivers/net/ethernet/netronome/nfp/flower/main.c in the Linux kernel before 5.3.4 allow attackers to cause a denial of service (memory consumption), aka CID-8572cea1461a.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
5.9 Medium
Exploitation
3% chance of attack within 30 days
Type
CWE-401Memory Leak
Timeline
Published18 Nov 2019
Updated30 Oct 2026
First seen21 Sep 2026
Sources
CVE-2019-19080 · NVD
CVE-2019-19080 · MITRE
Track software like this
Free during beta