Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.5
CVE-2019-13618: GPAC before 0.8.0 may crash due to memory over‑read
CVE-2019-13618 · published 7 years ago
Summary
The GPAC multimedia library (versions earlier than 0.8.0) can read past the end of a data buffer when processing certain media files, which may cause the application to crash. This could interrupt video or audio services that rely on GPAC. Upgrade GPAC to version 0.8.0 or later to resolve the issue.
What to do
- Update gpac gpac to version 0.8.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| gpac | gpac |
< 0.8.0 cpe:2.3:a:gpac:gpac:*:*:*:*:*:*:*:* |
Original advisory text
In GPAC before 0.8.0, isomedia/isom_read.c in libgpac.a has a heap-based buffer over-read, as demonstrated by a crash in gf_m2ts_sync in media_tools/mpegts.c.
In GPAC before 0.8.0, isomedia/isom_read.c in libgpac.a has a heap-based buffer over-read, as demonstrated by a crash in gf_m2ts_sync in media_tools/mpegts.c.
References
- https://github.com/gpac/gpac/compare/440d475...6b4ab40 Patch Third Party Advisory
- https://github.com/gpac/gpac/issues/1250 Exploit Patch Third Party Advisory
- https://lists.debian.org/debian-lts-announce/2020/01/msg00017.html
Internet-facing
14 days
Internal
60 days
- Not known to be exploited
- Can be exploited automatically (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-125Out-of-bounds Read
Timeline
Published16 Jul 2019
Updated29 Oct 2026
First seen29 Sep 2026
Sources
CVE-2019-13618 · NVD
Track software like this
Free during beta