Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2019-13127: draw.io Diagrams Plugin in Confluence Allows Malicious Input

CVE-2019-13127 · published 7 years ago
Summary

The draw.io plugin in Confluence and other products has a security flaw that can allow attackers to inject malicious code into the system. This could potentially lead to unauthorized actions or data theft. To fix this issue, update the plugin to version 8.3.14 or later.

What to do
  • Update drawio mxgraph to version 4.0.1.
  • Update draw draw.io_diagrams to version 8.3.14 or later.
Affected software
Ecosystem VendorProductAffected versions
npm drawio mxgraph <= 4.0.0
Fix: upgrade to 4.0.1
– draw draw.io_diagrams < 8.3.14
cpe:2.3:a:draw:draw.io_diagrams:*:*:*:*:*:confluence:*:*
– jgraph mxgraph <= 4.0.0
cpe:2.3:a:jgraph:mxgraph:*:*:*:*:*:*:*:*
Original advisory text
An issue was discovered in mxGraph through 4.0.0, related to the "draw.io Diagrams" plugin before 8.3.14 for Confluence and other products. Improper input validation/sanitization of a color field l...
An issue was discovered in mxGraph through 4.0.0, related to the "draw.io Diagrams" plugin before 8.3.14 for Confluence and other products. Improper input validation/sanitization of a color field leads to XSS. This is associated with javascript/examples/grapheditor/www/js/Dialogs.js.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
CWE-20Improper Input Validation
Timeline
Published1 Jul 2019
Updated31 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta