Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.8

CVE-2019-12816: ZNC Remote Users Can Execute Arbitrary Code

CVE-2019-12816 · published 7 years ago
Summary

A security issue in ZNC allows authenticated users to potentially take control of the server. This can happen if a malicious user loads a specially crafted module. We recommend updating to ZNC version 1.7.4-rc1 or later to fix this issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
znc znc <= 1.7.3
cpe:2.3:a:znc:znc:*:*:*:*:*:*:*:*
Original advisory text
Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.
Modules.cpp in ZNC before 1.7.4-rc1 allows remote authenticated non-admin users to escalate privileges and execute arbitrary code by loading a module with a crafted name.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
8.8 High
Exploitation
4% chance of attack within 30 days
Type
CWE-20Improper Input Validation
Timeline
Published15 Jun 2019
Updated22 Oct 2026
First seen11 Apr 2026
Sources
CVE-2019-12816 · NVD
Track software like this
Free during beta