Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.5
CVE-2019-12436: Samba 4.10.x before 4.10.5 may become unresponsive
CVE-2019-12436 · published 7 years ago
Summary
Versions of Samba 4.10 up to 4.10.4 that act as an Active Directory directory service can be forced to stop responding when someone with read permission sends a specially crafted request that asks for results in small batches. This can halt authentication and file‑sharing functions that rely on the directory. Upgrade to Samba 4.10.5 or later, or restrict read access to the directory, to prevent the issue.
What to do
- Update alpine samba to version 4.10.5-r0.
- Update samba samba to version 4.10.5 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Alpine:v3.10 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.11 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.12 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.13 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.14 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.15 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.16 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.17 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.18 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.19 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.20 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.21 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.22 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.23 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| Alpine:v3.24 | alpine | samba |
>= 4.10.0, < 4.10.5-r0 Fix: upgrade to 4.10.5-r0
|
| – | samba | samba |
>= 4.10.0, < 4.10.5 cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* |
| – | canonical | ubuntu_linux |
19.04 cpe:2.3:o:canonical:ubuntu_linux:19.04:*:*:*:*:*:*:* |
Original advisory text
Samba 4.10.x before 4.10.5 has a NULL pointer dereference, leading to an AD DC LDAP server Denial of Service. This is related to an attacker using the paged search control. The attacker must have d...
Samba 4.10.x before 4.10.5 has a NULL pointer dereference, leading to an AD DC LDAP server Denial of Service. This is related to an attacker using the paged search control. The attacker must have directory read access in order to attempt an exploit.
References
- http://www.securityfocus.com/bid/108823
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedorapro...
- https://usn.ubuntu.com/4018-1/ Third Party Advisory
- https://www.samba.org/samba/security/CVE-2019-12436.html Vendor Advisory
- https://www.synology.com/security/advisory/Synology_SA_19_27
- https://security.alpinelinux.org/vuln/CVE-2019-12436 Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-476NULL Pointer Dereference
Timeline
Published19 Jun 2019
Updated31 Oct 2026
First seen10 Sep 2026
Track software like this
Free during beta