Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.3

CVE-2019-10473: Jenkins Libvirt Slaves Plugin: Unauthorized access to credentials

CVE-2019-10473 · published 7 years ago
Summary

A security issue in the Jenkins Libvirt Slaves Plugin allows users with limited permissions to view sensitive credential IDs stored in Jenkins. This could potentially lead to unauthorized access to those credentials. To fix this, update the plugin to the latest version.

What to do
  • Update jenkins-ci org.jenkins-ci.plugins:libvirt-slave to version 1.8.6.
Affected software
Ecosystem VendorProductAffected versions
maven jenkins-ci org.jenkins-ci.plugins:libvirt-slave < 1.8.6
Fix: upgrade to 1.8.6
– jenkins libvirt_slaves <= 1.8.5
cpe:2.3:a:jenkins:libvirt_slaves:*:*:*:*:*:jenkins:*:*
Original advisory text
A missing permission check in Jenkins Libvirt Slaves Plugin in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.
A missing permission check in Jenkins Libvirt Slaves Plugin in form-related methods allowed users with Overall/Read access to enumerate credentials ID of credentials stored in Jenkins.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
4.3 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-276Incorrect Default Permissions
Timeline
Published23 Oct 2019
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta