Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.4
CVE-2019-10396: Jenkins Plugin Allows Attackers to Inject Harmful Code
CVE-2019-10396 · published 7 years ago
Summary
A security issue in the Jenkins Dashboard View Plugin allows an attacker to inject malicious code into Jenkins build descriptions, potentially harming users who view those descriptions. This could be exploited by users with permission to change build descriptions. Update to the latest version of the plugin to fix this issue.
What to do
- Update jenkins-ci org.jenkins-ci.plugins:dashboard-view to version 2.12.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| maven | jenkins-ci | org.jenkins-ci.plugins:dashboard-view |
< 2.12 Fix: upgrade to 2.12
|
| – | jenkins | dashboard_view |
<= 2.11 cpe:2.3:a:jenkins:dashboard_view:*:*:*:*:*:jenkins:*:* |
Original advisory text
Jenkins Dashboard View Plugin 2.11 and earlier did not escape build descriptions, resulting in a cross-site scripting vulnerability exploitable by users able to change build descriptions.
Jenkins Dashboard View Plugin 2.11 and earlier did not escape build descriptions, resulting in a cross-site scripting vulnerability exploitable by users able to change build descriptions.
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-10396
- https://jenkins.io/security/advisory/2019-09-12/#SECURITY-1489
- http://www.openwall.com/lists/oss-security/2019/09/12/2
- https://github.com/jenkinsci/dashboard-view-plugin/commit/115238da2a8899358b32ee...
- https://github.com/advisories/GHSA-fv4q-4h24-23qr
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published12 Sep 2019
Updated4 Nov 2026
First seen6 Mar 2026
Track software like this
Free during beta