Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.8
CVE-2018-4236: macOS before 10.13.5 lets malicious app run code
CVE-2018-4236 · published 8 years ago
Summary
Apple's macOS versions earlier than 10.13.5 contain a weakness in the graphics handling component. A specially crafted application could cause the system to run unwanted code with high privileges or crash the computer. Update macOS to version 10.13.5 or later to close the risk.
What to do
- Update apple mac_os_x to version 10.13.5 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| apple | mac_os_x |
< 10.13.5 cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in certain Apple products. macOS before 10.13.5 is affected. The issue involves the "IOGraphics" component. It allows attackers to execute arbitrary code in a privileged con...
An issue was discovered in certain Apple products. macOS before 10.13.5 is affected. The issue involves the "IOGraphics" component. It allows attackers to execute arbitrary code in a privileged context or cause a denial of service (memory corruption) via a crafted app.
References
- http://www.securitytracker.com/id/1041027 Third Party Advisory VDB Entry
- https://support.apple.com/HT208849 Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-119Buffer Overflow
Timeline
Published8 Jun 2018
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2018-4236 · NVD
Track software like this
Free during beta