Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.8
CVE-2018-4136: macOS <10.13.4 lets malicious app run as system
CVE-2018-4136 · published 8 years ago
Summary
Versions of macOS earlier than 10.13.4 can be tricked by a specially crafted application to run code with full system privileges or cause the system to crash. This means an attacker could take control of the computer or make it unusable. Update macOS to the latest version to close the gap.
What to do
- Update apple mac_os_x to version 10.13.4 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| apple | mac_os_x |
< 10.13.4 cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in certain Apple products. macOS before 10.13.4 is affected. The issue involves the "Kernel" component. It allows attackers to execute arbitrary code in a privileged context...
An issue was discovered in certain Apple products. macOS before 10.13.4 is affected. The issue involves the "Kernel" component. It allows attackers to execute arbitrary code in a privileged context or cause a denial of service (out-of-bounds read) via a crafted app.
References
- http://www.securityfocus.com/bid/103582 Third Party Advisory VDB Entry
- http://www.securitytracker.com/id/1040608 Third Party Advisory VDB Entry
- https://support.apple.com/HT208692 Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-125Out-of-bounds Read
Timeline
Published3 Apr 2018
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2018-4136 · NVD
Track software like this
Free during beta