Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
4.9

CVE-2018-2810: MySQL Server InnoDB can be crashed by remote attacker

CVE-2018-2810 · published 8 years ago
Summary

Versions of MySQL Server up to 5.7.21 that include the InnoDB storage engine are vulnerable. An attacker with network access can cause the database to freeze or repeatedly crash, leading to a denial of service. Upgrade MySQL Server (and any NetApp products that embed this component) to the latest available release to protect against this risk.

What to do
  • Update mariadb mariadb to version 10.2.15 or later.
Affected software
VendorProductAffected versions
oracle mysql >= 5.7.0, <= 5.7.21
cpe:2.3:a:oracle:mysql:*:*:*:*:*:*:*:*
netapp active_iq_unified_manager >= 7.3
>= 9.5
cpe:2.3:a:netapp:active_iq_unified_manager:*:*:*:*:*:windows:*:*
netapp oncommand_insight All versions
cpe:2.3:a:netapp:oncommand_insight:-:*:*:*:*:*:*:*
netapp oncommand_workflow_automation All versions
cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*
netapp snapcenter All versions
cpe:2.3:a:netapp:snapcenter:-:*:*:*:*:*:*:*
canonical ubuntu_linux 14.04
16.04
18.04
18.10
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:esm:*:*:*
mariadb mariadb >= 10.2.0, < 10.2.15
cpe:2.3:a:mariadb:mariadb:*:*:*:*:*:*:*:*
Original advisory text
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.7.21 and prior. Easily exploitable vulnerability allows high privilege...
Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: InnoDB). Supported versions that are affected are 5.7.21 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 4.9 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H).
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit
  • Gives an attacker partial control
Severity
4.9 Medium
Exploitation
3% chance of attack within 30 days
Timeline
Published19 Apr 2018
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2018-2810 · NVD
Track software like this
Free during beta