Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2018-21207: Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, D7800 before 1.0.1.30, EX2700 before...
CVE-2018-21207 · published 6 years ago
Summary
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, D7800 before 1.0.1.30, EX2700 before 1.0.1.28, R6100 before 1.0.1.20, R7500 before 1.0.0.118, R7500v2 before 1.0.3.24, R7800 before 1.0.2.4...
What to do
- Update netgear d3600_firmware to version 1.0.0.67 or later.
- Update netgear d6000_firmware to version 1.0.0.67 or later.
- Update netgear d7800_firmware to version 1.0.1.30 or later.
- Update netgear ex2700_firmware to version 1.0.1.28 or later.
- Update netgear r6100_firmware to version 1.0.1.20 or later.
- Update netgear r7800_firmware to version 1.0.2.40 or later.
- Update netgear r900_firmware to version 1.0.2.52 or later.
- Update netgear wn2000rpt_firmware to version 1.0.1.20 or later.
- Update netgear wn3000rp_firmware to version 1.0.2.50 or later.
- Update netgear wn3100rp_firmware to version 1.0.0.56 or later.
- Update netgear wndr3700_firmware to version 1.0.2.96 or later.
- Update netgear wndr4500_firmware to version 1.0.0.50 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| netgear | d3600_firmware |
< 1.0.0.67 cpe:2.3:o:netgear:d3600_firmware:*:*:*:*:*:*:*:* |
| netgear | d6000_firmware |
< 1.0.0.67 cpe:2.3:o:netgear:d6000_firmware:*:*:*:*:*:*:*:* |
| netgear | d7800_firmware |
< 1.0.1.30 cpe:2.3:o:netgear:d7800_firmware:*:*:*:*:*:*:*:* |
| netgear | ex2700_firmware |
< 1.0.1.28 cpe:2.3:o:netgear:ex2700_firmware:*:*:*:*:*:*:*:* |
| netgear | r6100_firmware |
< 1.0.1.20 cpe:2.3:o:netgear:r6100_firmware:*:*:*:*:*:*:*:* |
| netgear | r7500_firmware |
< 1.0.0.118 < 1.0.3.24 cpe:2.3:o:netgear:r7500_firmware:*:*:*:*:*:*:*:* |
| netgear | r7800_firmware |
< 1.0.2.40 cpe:2.3:o:netgear:r7800_firmware:*:*:*:*:*:*:*:* |
| netgear | r900_firmware |
< 1.0.2.52 cpe:2.3:o:netgear:r900_firmware:*:*:*:*:*:*:*:* |
| netgear | wn2000rpt_firmware |
< 1.0.1.20 cpe:2.3:o:netgear:wn2000rpt_firmware:*:*:*:*:*:*:*:* |
| netgear | wn3000rp_firmware |
< 1.0.2.50 cpe:2.3:o:netgear:wn3000rp_firmware:*:*:*:*:*:*:*:* |
| netgear | wn3100rp_firmware |
< 1.0.0.56 cpe:2.3:o:netgear:wn3100rp_firmware:*:*:*:*:*:*:*:* |
| netgear | wndr3700_firmware |
< 1.0.2.96 cpe:2.3:o:netgear:wndr3700_firmware:*:*:*:*:*:*:*:* |
| netgear | wndr4300_firmware |
< 1.0.2.98 < 1.0.0.50 cpe:2.3:o:netgear:wndr4300_firmware:*:*:*:*:*:*:*:* |
| netgear | wndr4500_firmware |
< 1.0.0.50 cpe:2.3:o:netgear:wndr4500_firmware:*:*:*:*:*:*:*:* |
Original advisory text
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, D7800 before 1.0.1.30, EX2700 before...
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, D7800 before 1.0.1.30, EX2700 before 1.0.1.28, R6100 before 1.0.1.20, R7500 before 1.0.0.118, R7500v2 before 1.0.3.24, R7800 before 1.0.2.40, R9000 before 1.0.2.52, WN2000RPTv3 before 1.0.1.20, WN3000RPv3 before 1.0.2.50, WN3100RPv2 before 1.0.0.56, WNDR3700v4 before 1.0.2.96, WNDR4300 before 1.0.2.98, WNDR4300v2 before 1.0.0.50, and WNDR4500v3 before 1.0.0.50.
References
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-787Out-of-bounds Write
Timeline
Published28 Apr 2020
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2018-21207 · NVD
Track software like this
Free during beta