Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.2
CVE-2018-20911: cPanel before 70.0.23 can let attackers run code
CVE-2018-20911 · published 7 years ago
Summary
Versions of cPanel older than 70.0.23 expose a flaw that lets a remote user execute their own programs while the system checks a component. This could allow unwanted code to run on your server, potentially compromising data or services. Upgrade cPanel to version 70.0.23 or later to close the issue.
What to do
- Update cpanel cpanel to version 70.0.23 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| cpanel | cpanel |
< 70.0.23 cpe:2.3:a:cpanel:cpanel:*:*:*:*:*:*:*:* |
Original advisory text
cPanel before 70.0.23 allows code execution because "." is in @INC during a Perl syntax check of cpaddonsup (SEC-359).
cPanel before 70.0.23 allows code execution because "." is in @INC during a Perl syntax check of cpaddonsup (SEC-359).
References
- https://documentation.cpanel.net/display/CL/70+Change+Log Release Notes Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published1 Aug 2019
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2018-20911 · NVD
Track software like this
Free during beta