Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.1

CVE-2018-20244: Apache Airflow: Malicious Admin Can Execute Arbitrary JavaScript

CVE-2018-20244 · published 7 years ago
Summary

A security issue in older versions of Apache Airflow allows a malicious administrator to inject malicious code into certain web pages. This could potentially lead to unauthorized actions or data exposure. Update to version 1.10.2 or later to fix this issue.

What to do
  • Update apache software foundation apache-airflow to version 1.10.2.
  • Update apache airflow to version 1.10.2 or later.
Affected software
Ecosystem VendorProductAffected versions
pip apache software foundation apache-airflow < 1.10.2
Fix: upgrade to 1.10.2
– apache airflow < 1.10.2
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*
Original advisory text
In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.
In Apache Airflow before 1.10.2, a malicious admin user could edit the state of objects in the Airflow metadata database to execute arbitrary javascript on certain page views.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.1 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 Feb 2019
Updated4 Nov 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta