Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2018-15585: GNUBOARD lets attackers add malicious web code

CVE-2018-15585 · published 7 years ago
Summary

The GNUBOARD website software (versions before 5.3.1.6) can be tricked into inserting harmful code through a popup title field. This could let a remote user run unwanted actions in a visitor’s browser, potentially stealing information or altering what the user sees. Install the latest GNUBOARD update or apply the vendor’s fix to stop this risk.

What to do
  • Update sir gnuboard to version 5.3.1.6 or later.
Affected software
VendorProductAffected versions
sir gnuboard < 5.3.1.6
cpe:2.3:a:sir:gnuboard:*:*:*:*:*:*:*:*
Original advisory text
Cross-Site Scripting (XSS) vulnerability in newwinform.php in GNUBOARD5 before 5.3.1.6 allows remote attackers to inject arbitrary web script or HTML via the popup title parameter.
Cross-Site Scripting (XSS) vulnerability in newwinform.php in GNUBOARD5 before 5.3.1.6 allows remote attackers to inject arbitrary web script or HTML via the popup title parameter.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published27 Mar 2019
Updated31 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta