Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.0

CVE-2018-14633: Linux kernel iSCSI target can crash or expose data

CVE-2018-14633 · published 8 years ago
Summary

The iSCSI target code in Linux kernels (including Ubuntu, Debian and Red Hat Enterprise editions) can be tricked into overwriting memory, which may cause the system to stop working or, in rare cases, let an attacker see data stored on the iSCSI target. The problem only appears when the iSCSI target feature is turned on. Apply the latest kernel updates from your distribution as soon as they are available to fix the issue.

What to do
  • Update canonical linux to version 3.13.0-160.210.
  • Update canonical linux-aws to version 4.4.0-1031.34.
  • Update canonical linux-azure to version 4.15.0-1031.32~14.04.1.
  • Update canonical linux-lts-xenial to version 4.4.0-137.163~14.04.1.
  • Update canonical linux to version 4.4.0-137.163.
  • Update canonical linux-aws to version 4.4.0-1069.79.
  • Update canonical linux-azure to version 4.15.0-1025.26~16.04.1.
  • Update canonical linux-gcp to version 4.15.0-1021.22~16.04.1.
  • Update canonical linux-hwe to version 4.15.0-36.39~16.04.1.
  • Update canonical linux-kvm to version 4.4.0-1035.41.
  • Update canonical linux-raspi2 to version 4.4.0-1098.106.
  • Update canonical linux-snapdragon to version 4.4.0-1102.107.
  • Update canonical linux-fips to version 4.4.0-1008.10.
  • Update canonical linux to version 4.15.0-36.39.
  • Update canonical linux-aws to version 4.15.0-1023.23.
  • Update canonical linux-azure to version 4.15.0-1025.26.
  • Update canonical linux-gcp to version 4.15.0-1021.22.
  • Update canonical linux-kvm to version 4.15.0-1023.23.
  • Update canonical linux-oem to version 4.15.0-1021.24.
  • Update canonical linux-raspi2 to version 4.15.0-1024.26.
  • Update debian linux to version 4.18.10-1.
Affected software
Ecosystem VendorProductAffected versions
– linux linux_kernel >= 3.1, < 3.16.59
>= 3.17, < 3.18.124
>= 3.19, < 4.4.159
>= 4.5, < 4.9.130
>= 4.10, < 4.14.73
>= 4.15, < 4.18.11
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
– canonical ubuntu_linux 12.04
14.04
16.04
18.04
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:*
– debian debian_linux 8.0
9.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
– redhat enterprise_linux_eus 7.4
7.6
cpe:2.3:o:redhat:enterprise_linux_eus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_server 7.0
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
– redhat enterprise_linux_server_aus 7.4
7.6
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_server_tus 7.4
7.6
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_workstation 7.0
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*
Ubuntu:14.04:LTS canonical linux < 3.13.0-160.210
Fix: upgrade to 3.13.0-160.210
Ubuntu:14.04:LTS canonical linux-aws < 4.4.0-1031.34
Fix: upgrade to 4.4.0-1031.34
Ubuntu:14.04:LTS canonical linux-azure < 4.15.0-1031.32~14.04.1
Fix: upgrade to 4.15.0-1031.32~14.04.1
Ubuntu:14.04:LTS canonical linux-lts-xenial < 4.4.0-137.163~14.04.1
Fix: upgrade to 4.4.0-137.163~14.04.1
Ubuntu:16.04:LTS canonical linux < 4.4.0-137.163
Fix: upgrade to 4.4.0-137.163
Ubuntu:16.04:LTS canonical linux-aws < 4.4.0-1069.79
Fix: upgrade to 4.4.0-1069.79
Ubuntu:16.04:LTS canonical linux-azure < 4.15.0-1025.26~16.04.1
Fix: upgrade to 4.15.0-1025.26~16.04.1
Ubuntu:16.04:LTS canonical linux-gcp < 4.15.0-1021.22~16.04.1
Fix: upgrade to 4.15.0-1021.22~16.04.1
Ubuntu:16.04:LTS canonical linux-hwe < 4.15.0-36.39~16.04.1
Fix: upgrade to 4.15.0-36.39~16.04.1
Ubuntu:16.04:LTS canonical linux-kvm < 4.4.0-1035.41
Fix: upgrade to 4.4.0-1035.41
Ubuntu:16.04:LTS canonical linux-raspi2 < 4.4.0-1098.106
Fix: upgrade to 4.4.0-1098.106
Ubuntu:16.04:LTS canonical linux-snapdragon < 4.4.0-1102.107
Fix: upgrade to 4.4.0-1102.107
Ubuntu:Pro:FIPS-updates:16.04:LTS canonical linux-fips < 4.4.0-1008.10
Fix: upgrade to 4.4.0-1008.10
Ubuntu:18.04:LTS canonical linux < 4.15.0-36.39
Fix: upgrade to 4.15.0-36.39
Ubuntu:18.04:LTS canonical linux-aws < 4.15.0-1023.23
Fix: upgrade to 4.15.0-1023.23
Ubuntu:18.04:LTS canonical linux-azure < 4.15.0-1025.26
Fix: upgrade to 4.15.0-1025.26
Ubuntu:18.04:LTS canonical linux-gcp < 4.15.0-1021.22
Fix: upgrade to 4.15.0-1021.22
Ubuntu:18.04:LTS canonical linux-kvm < 4.15.0-1023.23
Fix: upgrade to 4.15.0-1023.23
Ubuntu:18.04:LTS canonical linux-oem < 4.15.0-1021.24
Fix: upgrade to 4.15.0-1021.24
Ubuntu:18.04:LTS canonical linux-raspi2 < 4.15.0-1024.26
Fix: upgrade to 4.15.0-1024.26
Ubuntu:20.04:LTS canonical linux-azure-fde All versions
Ubuntu:20.04:LTS canonical linux-gke All versions
Ubuntu:20.04:LTS canonical linux-raspi2 All versions
Ubuntu:20.04:LTS canonical linux-riscv All versions
Ubuntu:22.04:LTS canonical linux-intel-iot-realtime All versions
Ubuntu:22.04:LTS canonical linux-realtime All versions
Ubuntu:24.04:LTS canonical linux-raspi-realtime All versions
Debian:12 debian linux < 4.18.10-1
Fix: upgrade to 4.18.10-1
Original advisory text
A security flaw was found in the chap_server_compute_md5() function in the ISCSI target code in the Linux kernel in a way an authentication request from an ISCSI initiator is processed. An unauthen...
A security flaw was found in the chap_server_compute_md5() function in the ISCSI target code in the Linux kernel in a way an authentication request from an ISCSI initiator is processed. An unauthenticated remote attacker can cause a stack buffer overflow and smash up to 17 bytes of the stack. The attack requires the iSCSI target to be enabled on the victim host. Depending on how the target's code was built (i.e. depending on a compiler, compile flags and hardware architecture) an attack may lead to a system crash and thus to a denial-of-service or possibly to a non-authorized access to data exported by an iSCSI target. Due to the nature of the flaw, privilege escalation cannot be fully ruled out, although we believe it is highly unlikely. Kernel versions 4.18.x, 4.14.x and 3.10.x are believed to be vulnerable.
References
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.0 High
Exploitation
9% chance of attack within 30 days
Type
CWE-121Stack-based Buffer Overflow
CWE-787Out-of-bounds Write
Timeline
Published25 Sep 2018
Updated21 Oct 2026
First seen29 Sep 2026
Track software like this
Free during beta