Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2018-14467: tcpdump may read extra data when handling BGP traffic

CVE-2018-14467 · published 7 years ago
Summary

The BGP processing code in tcpdump versions before 4.9.3 can read past the intended memory area, which could cause the program to crash or behave unexpectedly. This affects systems using tcpdump on macOS, Debian, Fedora, and openSUSE Leap. Upgrade tcpdump to version 4.9.3 or later to resolve the issue.

What to do
  • Update tcpdump tcpdump to version 4.9.3 or later.
  • Update apple mac_os_x to version 10.15.2 or later.
Affected software
VendorProductAffected versions
tcpdump tcpdump < 4.9.3
cpe:2.3:a:tcpdump:tcpdump:*:*:*:*:*:*:*:*
apple mac_os_x < 10.15.2
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
debian debian_linux 8.0
9.0
10.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
fedoraproject fedora 29
30
31
cpe:2.3:o:fedoraproject:fedora:29:*:*:*:*:*:*:*
opensuse leap 15.0
15.1
cpe:2.3:o:opensuse:leap:15.0:*:*:*:*:*:*:*
redhat enterprise_linux 7.0
8.0
cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:*
Original advisory text
The BGP parser in tcpdump before 4.9.3 has a buffer over-read in print-bgp.c:bgp_capabilities_print() (BGP_CAPCODE_MP).
The BGP parser in tcpdump before 4.9.3 has a buffer over-read in print-bgp.c:bgp_capabilities_print() (BGP_CAPCODE_MP).
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker partial control
Severity
7.5 High
Exploitation
4% chance of attack within 30 days
Type
CWE-125Out-of-bounds Read
Timeline
Published3 Oct 2019
Updated24 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta