Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2018-14040: Bootstrap 4.1.1 and earlier: Malicious JavaScript in collapsed menu headers
CVE-2018-14040 · published 8 years ago
Summary
Using Bootstrap in a web application, attackers could inject malicious JavaScript code into menu headers that are collapsed. This could lead to unauthorized actions on the website. Update Bootstrap to version 4.1.2 or later to fix this vulnerability.
What to do
- Update mdo bootstrap to version 4.1.2.
- Update twitter bootstrap to version 4.1.2.
- Update mdo bootstrap to version 3.4.0.
- Update twitter bootstrap to version 3.4.0.
- Update webjars org.webjars:bootstrap to version 4.1.2.
- Update webjars org.webjars:bootstrap to version 3.4.0.
- Update thomas mcdonald bootstrap-sass to version 3.4.0.
- Update twbs bootstrap to version 3.4.0.
- Update twbs bootstrap to version 4.1.2.
- Update the bootstrap authors bootstrap.sass to version 4.1.2.
- Update the bootstrap authors bootstrap to version 3.4.0.
- Update the bootstrap authors bootstrap to version 4.1.2.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| npm | mdo | bootstrap |
>= 4.0.0, < 4.1.2 >= 2.3.0, < 3.4.0 Fix: upgrade to 4.1.2
|
| rubygems | bootstrap |
>= 4.0.0, < 4.1.2 >= 2.3.0, < 3.4.0 Fix: upgrade to 4.1.2
|
|
| maven | webjars | org.webjars:bootstrap |
>= 4.0.0, < 4.1.2 >= 2.3.0, < 3.4.0 Fix: upgrade to 4.1.2
|
| rubygems | thomas mcdonald | bootstrap-sass |
>= 2.3.0, < 3.4.0 Fix: upgrade to 3.4.0
|
| composer | twbs | bootstrap |
>= 2.3.0, < 3.4.0 >= 4.0.0, < 4.1.2 Fix: upgrade to 3.4.0
|
| – | debian | debian_linux |
8.0 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* |
| – | getbootstrap | bootstrap |
< 3.4.0 >= 4.0.0, < 4.1.2 4.0.0 cpe:2.3:a:getbootstrap:bootstrap:*:*:*:*:*:*:*:* |
| nuget | the bootstrap authors | bootstrap.sass |
>= 4.0.0, < 4.1.2 Fix: upgrade to 4.1.2
|
| nuget | the bootstrap authors | bootstrap |
>= 2.3.0, < 3.4.0 >= 4.0.0, < 4.1.2 Fix: upgrade to 3.4.0
|
Original advisory text
In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.
In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.
References
- https://github.com/twbs/bootstrap/pull/26630
- https://nvd.nist.gov/vuln/detail/CVE-2018-14040
- https://github.com/twbs/bootstrap/issues/26423
- https://github.com/twbs/bootstrap/issues/26625
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e...
- https://lists.apache.org/thread.html/52e0e6b5df827ee7f1e68f7cc3babe61af3b2160f5d...
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12e...
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d28...
- https://lists.apache.org/thread.html/r3dc0cac8d856bca02bd6997355d7ff83027dcfc82f...
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995...
- https://lists.debian.org/debian-lts-announce/2018/08/msg00027.html
- https://seclists.org/bugtraq/2019/May/18
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-14
- http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies...
- http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.htm...
- http://seclists.org/fulldisclosure/2019/May/10
- http://seclists.org/fulldisclosure/2019/May/11
- http://seclists.org/fulldisclosure/2019/May/13
- https://github.com/twbs/bootstrap/blob/v3.4.1/js/collapse.js#L140
- https://github.com/twbs/bootstrap/blob/v3.4.1/js/scrollspy.js#L56
- https://github.com/twbs/bootstrap/blob/v3.4.1/js/tooltip.js#L352
- https://github.com/twbs/bootstrap-rubygem/commit/f34c43c936ac7d0ebb129289321d8c5...
- https://github.com/twbs/bootstrap/commit/149096016f70fd815540d62c0989fd99cdc809e...
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/bootstrap/CVE-2018-...
- https://github.com/twbs/bootstrap/commit/2a5ba23ce8f041f3548317acc992ed8a736b609...
- https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/bootstrap-sass/CVE-...
- https://github.com/advisories/GHSA-3wqf-4x89-9g79
- https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/ Vendor Advisory
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e...
- https://lists.apache.org/thread.html/52e0e6b5df827ee7f1e68f7cc3babe61af3b2160f5d...
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12e...
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d28...
- https://lists.apache.org/thread.html/r3dc0cac8d856bca02bd6997355d7ff83027dcfc82f...
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995...
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published13 Jul 2018
Updated24 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta