Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.9

CVE-2018-1108: Linux kernel before 4.17-rc1 may expose weak random seed

CVE-2018-1108 · published 8 years ago
Summary

Linux kernel versions earlier than 4.17-rc1 can provide predictable random numbers during the very first moments after a system starts. This makes it easier for attackers to guess keys or tokens that rely on randomness, potentially weakening security controls. Upgrade the kernel to a version newer than 4.17-rc1 (or apply your distribution's security updates) to ensure proper random seed generation.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
linux linux_kernel <= 4.16
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
canonical ubuntu_linux 16.04
18.04
cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
debian debian_linux 9.0
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
Original advisory text
kernel drivers before version 4.17-rc1 are vulnerable to a weakness in the Linux kernel's implementation of random seed data. Programs, early in the boot sequence, could use the data allocated for ...
kernel drivers before version 4.17-rc1 are vulnerable to a weakness in the Linux kernel's implementation of random seed data. Programs, early in the boot sequence, could use the data allocated for the seed before it was sufficiently generated.
References
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.9 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-330Use of Insufficiently Random Values
Timeline
Published21 May 2018
Updated30 Oct 2026
First seen29 Sep 2026
Sources
CVE-2018-1108 · NVD
Track software like this
Free during beta