Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
5.5
CVE-2018-1000079: RubyGems: Malicious Gems Can Write to Unintended Filesystem Locations
CVE-2018-1000079 · published 8 years ago
Summary
RubyGems versions 2.2.9 and earlier, 2.3.6 and earlier, 2.4.3 and earlier, 2.5.0 and earlier are at risk of allowing malicious gems to install themselves in unintended locations on your system. This could lead to security issues if you install a fake or malicious gem. Update to version 2.7.6 or later to fix this issue.
What to do
- Update jim weirich rubygems-update to version 2.7.6.
- Update jruby org.jruby:jruby-stdlib to version 9.1.16.0.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| rubygems | jim weirich | rubygems-update |
< 2.7.6 Fix: upgrade to 2.7.6
|
| maven | jruby | org.jruby:jruby-stdlib |
< 9.1.16.0 Fix: upgrade to 9.1.16.0
|
| – | rubygems | rubygems |
<= 2.2.9 <= 2.3.6 <= 2.4.3 <= 2.5.0 cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:* |
Original advisory text
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contai...
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000079
- https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db92...
- https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241d...
- https://access.redhat.com/errata/RHSA-2018:3729
- https://access.redhat.com/errata/RHSA-2018:3730
- https://access.redhat.com/errata/RHSA-2018:3731
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://usn.ubuntu.com/3621-1/
- https://www.debian.org/security/2018/dsa-4219
- https://www.debian.org/security/2018/dsa-4259
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7
- https://github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0c...
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895778
- https://security-tracker.debian.org/tracker/CVE-2018-1000079
- https://github.com/advisories/GHSA-8qxg-mff5-j3wc
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-22Path Traversal
Timeline
Published13 Mar 2018
Updated31 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta