Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
6.1

CVE-2017-9061: WordPress may run malicious code on large file upload errors

CVE-2017-9061 · published 9 years ago
Summary

When someone tries to upload an overly large file to a WordPress site version older than 4.7.5, the error message can display the file name without cleaning it. An attacker could craft a file name that includes code, causing the site to run unwanted scripts in the browser of anyone viewing the error. Update WordPress to version 4.7.5 or later, or apply available patches, to stop this behavior.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
wordpress wordpress <= 4.7.4
cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*
debian debian_linux 8.0
9.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
Original advisory text
In WordPress before 4.7.5, a cross-site scripting (XSS) vulnerability exists when attempting to upload very large files, because the error message does not properly restrict presentation of the fil...
In WordPress before 4.7.5, a cross-site scripting (XSS) vulnerability exists when attempting to upload very large files, because the error message does not properly restrict presentation of the filename.
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
6.1 Medium
Exploitation
2% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published18 May 2017
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2017-9061 · NVD
Track software like this
Free during beta