Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.8
CVE-2017-2358: macOS versions before 10.12.3 can let malicious apps run code
CVE-2017-2358 · published 9 years ago
Summary
Apple's macOS versions earlier than 10.12.3 have a weakness in the graphics driver that could let a specially crafted application take control of the system or cause it to crash. This could let an attacker run programs with high privileges, potentially stealing data or disrupting operations. Upgrade macOS to version 10.12.3 or later to fix the problem.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| apple | mac_os_x |
<= 10.12.2 cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in certain Apple products. macOS before 10.12.3 is affected. The issue involves the "Graphics Drivers" component. It allows attackers to execute arbitrary code in a privileg...
An issue was discovered in certain Apple products. macOS before 10.12.3 is affected. The issue involves the "Graphics Drivers" component. It allows attackers to execute arbitrary code in a privileged context or cause a denial of service (memory corruption) via a crafted app.
References
- http://www.securityfocus.com/bid/95723 Third Party Advisory VDB Entry
- http://www.securitytracker.com/id/1037671
- https://support.apple.com/HT207483 Vendor Advisory
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-119Buffer Overflow
Timeline
Published20 Feb 2017
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2017-2358 · NVD
Track software like this
Free during beta