Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
5.4

CVE-2017-2127: YOP Poll before 5.8.1 lets attackers run malicious scripts

CVE-2017-2127 · published 9 years ago
Summary

The YOP Poll plugin versions earlier than 5.8.1 can be tricked into inserting and executing unwanted code in a web page. This could let a remote attacker display fake content, steal information, or hijack user sessions. Update the plugin to version 5.8.1 or later, or apply the vendor’s patch, to stop the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
yop-poll yop_poll <= 5.8
cpe:2.3:a:yop-poll:yop_poll:*:*:*:*:*:wordpress:*:*
Original advisory text
Cross-site scripting vulnerability in YOP Poll versions prior to 5.8.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Cross-site scripting vulnerability in YOP Poll versions prior to 5.8.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
References
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
5.4 Medium
Exploitation
<1% chance of attack within 30 days
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published28 Apr 2017
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2017-2127 · NVD
Track software like this
Free during beta