Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
4.8
CVE-2017-18809: NETGEAR ReadyNAS OS 6 devices running ReadyNAS OS versions prior to 6.8.0 are affected by stored XSS.
CVE-2017-18809 · published 6 years ago
Summary
NETGEAR ReadyNAS OS 6 devices running ReadyNAS OS versions prior to 6.8.0 are affected by stored XSS.
What to do
- Update netgear readynas_os to version 6.8.0 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| netgear | readynas_os |
>= 6.0, < 6.8.0 cpe:2.3:o:netgear:readynas_os:*:*:*:*:*:*:*:* |
Original advisory text
NETGEAR ReadyNAS OS 6 devices running ReadyNAS OS versions prior to 6.8.0 are affected by stored XSS.
NETGEAR ReadyNAS OS 6 devices running ReadyNAS OS versions prior to 6.8.0 are affected by stored XSS.
References
- https://kb.netgear.com/000049056/Security-Advisory-for-Stored-Cross-Site-Scripti... Patch Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published21 Apr 2020
Updated4 Nov 2026
First seen29 Sep 2026
Sources
CVE-2017-18809 · NVD
Track software like this
Free during beta