Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.8
CVE-2017-18754: Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WNDR3700v4 before 1.0.2.88, WNDR4300v1 before 1.0.2.90, and WNR2000v5 before 1.0.0.58.
CVE-2017-18754 · published 6 years ago
Summary
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WNDR3700v4 before 1.0.2.88, WNDR4300v1 before 1.0.2.90, and WNR2000v5 before 1.0.0.58.
What to do
- Update netgear wndr3700_firmware to version 1.0.2.88 or later.
- Update netgear wndr4300_firmware to version 1.0.2.90 or later.
- Update netgear wnr2000_firmware to version 1.0.0.58 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| netgear | wndr3700_firmware |
< 1.0.2.88 cpe:2.3:o:netgear:wndr3700_firmware:*:*:*:*:*:*:*:* |
| netgear | wndr4300_firmware |
< 1.0.2.90 cpe:2.3:o:netgear:wndr4300_firmware:*:*:*:*:*:*:*:* |
| netgear | wnr2000_firmware |
< 1.0.0.58 cpe:2.3:o:netgear:wnr2000_firmware:*:*:*:*:*:*:*:* |
Original advisory text
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WNDR3700v4 before 1.0.2.88, WNDR4300v1 before 1.0.2.90, and WNR2000v5 before 1.0.0.58.
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects WNDR3700v4 before 1.0.2.88, WNDR4300v1 before 1.0.2.90, and WNR2000v5 before 1.0.0.58.
References
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-74Injection
Timeline
Published22 Apr 2020
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2017-18754 · NVD
Track software like this
Free during beta