Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
6.1
CVE-2017-18085: Confluence Server before 6.6.1 lets attackers add malicious code
CVE-2017-18085 · published 8 years ago
Summary
A page in Confluence Server versions earlier than 6.6.1 can be tricked into showing any HTML or JavaScript an attacker chooses. This could let a remote attacker steal information, hijack user sessions, or change what users see. Upgrade Confluence to version 6.6.1 or later, or apply the vendor's recommended patch, to close the risk.
What to do
- Update atlassian confluence to version 6.6.1 or later.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| atlassian | confluence |
< 6.6.1 cpe:2.3:a:atlassian:confluence:*:*:*:*:*:*:*:* |
Original advisory text
The viewdefaultdecorator resource in Atlassian Confluence Server before version 6.6.1 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability t...
The viewdefaultdecorator resource in Atlassian Confluence Server before version 6.6.1 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the key parameter.
References
- http://www.securityfocus.com/bid/103062 Third Party Advisory VDB Entry
- https://jira.atlassian.com/browse/CONFSERVER-54905 Issue Tracking Vendor Advisory
Internet-facing
60 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker partial control (estimated)
Type
CWE-79Cross-site Scripting (XSS)
Timeline
Published2 Feb 2018
Updated31 Oct 2026
First seen29 Sep 2026
Sources
CVE-2017-18085 · NVD
Track software like this
Free during beta