Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2017-14746: Samba 4.x lets attackers run code via SMB1

CVE-2017-14746 · published 8 years ago
Summary

Versions of Samba 4.x older than 4.7.3 on Ubuntu, Debian, and Red Hat systems can be tricked into running any program an attacker chooses when they send a specially crafted SMB1 network request. This could let an outsider take control of the server or steal data. Upgrade Samba to version 4.7.3 or later, or disable SMB1 support, to block the risk.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
samba samba >= 4.0.0, < 4.5.0
>= 4.5.0, < 4.5.15
>= 4.6.0, < 4.6.11
>= 4.7.0, < 4.7.3
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*
canonical ubuntu_linux 14.04
16.04
17.04
17.10
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
debian debian_linux 8.0
9.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
redhat enterprise_linux_desktop 6.0
7.0
cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
redhat enterprise_linux_server 6.0
7.0
cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
redhat enterprise_linux_workstation 6.0
7.0
cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*
Original advisory text
Use-after-free vulnerability in Samba 4.x before 4.7.3 allows remote attackers to execute arbitrary code via a crafted SMB1 request.
Use-after-free vulnerability in Samba 4.x before 4.7.3 allows remote attackers to execute arbitrary code via a crafted SMB1 request.
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
9.8 Critical
Exploitation
10% chance of attack within 30 days
Type
CWE-416Use After Free
Timeline
Published27 Nov 2017
Updated15 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta