Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2017-13024: tcpdump can over-read data and crash

CVE-2017-13024 · published 9 years ago
Summary

The network capture tool tcpdump may read beyond the end of a data buffer when handling IPv6 mobility information, which could cause the program to stop working. This affects versions before 4.9.2 on Linux systems such as Debian. Update tcpdump to version 4.9.2 or later to prevent the issue.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
tcpdump tcpdump <= 4.9.1
cpe:2.3:a:tcpdump:tcpdump:*:*:*:*:*:*:*:*
debian debian_linux 8.0
9.0
10.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
Original advisory text
The IPv6 mobility parser in tcpdump before 4.9.2 has a buffer over-read in print-mobility.c:mobility_opt_print().
The IPv6 mobility parser in tcpdump before 4.9.2 has a buffer over-read in print-mobility.c:mobility_opt_print().
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically
  • Gives an attacker full control
Severity
9.8 Critical
Exploitation
3% chance of attack within 30 days
Type
CWE-125Out-of-bounds Read
Timeline
Published14 Sep 2017
Updated4 Nov 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta