Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.8

CVE-2017-12608: Apache OpenOffice Writer can crash from crafted DOC

CVE-2017-12608 · published 8 years ago
Summary

Versions of Apache OpenOffice Writer before 4.1.4 can be forced to stop working by a specially made Word document. The crash could let an attacker run unwanted code on the computer. Update OpenOffice Writer to version 4.1.4 or later, or avoid opening untrusted DOC files.

What to do
  • Update apache openoffice to version 4.1.4 or later.
Affected software
VendorProductAffected versions
apache openoffice < 4.1.4
cpe:2.3:a:apache:openoffice:*:*:*:*:*:*:*:*
debian debian_linux 7.0
8.0
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
Original advisory text
A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memo...
A vulnerability in Apache OpenOffice Writer DOC file parser before 4.1.4, and specifically in ImportOldFormatStyles, allows attackers to craft malicious documents that cause denial of service (memory corruption and application crash) potentially resulting in arbitrary code execution.
Fix within
Internet-facing 14 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker full control (estimated)
Severity
7.8 High
Exploitation
3% chance of attack within 30 days
Type
CWE-787Out-of-bounds Write
Timeline
Published20 Nov 2017
Updated30 Oct 2026
First seen29 Sep 2026
Sources
Track software like this
Free during beta