Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2017-1000048: qs module in web framework causes crash on malicious request

CVE-2017-1000048 · published 9 years ago
Summary

Using an outdated version of the qs module in your web framework can cause your website to crash if a malicious user sends a specially crafted request. This could make your website unavailable to legitimate users. Update to a patched version of the qs module to prevent this.

What to do
  • Update ljharb qs to version 6.0.4.
  • Update ljharb qs to version 6.1.2.
  • Update ljharb qs to version 6.2.3.
  • Update ljharb qs to version 6.3.2.
Affected software
Ecosystem VendorProductAffected versions
npm ljharb qs < 6.0.4
>= 6.1.0, < 6.1.2
>= 6.2.0, < 6.2.3
>= 6.3.0, < 6.3.2
Fix: upgrade to 6.0.4
– qs_project qs 1.0.0
1.0.1
1.0.2
1.1.0
1.2.0
1.2.1
2.3.1
2.3.2
2.3.3
2.4.0
2.4.1
2.4.2
18 more version ranges
cpe:2.3:a:qs_project:qs:1.0.0:*:*:*:*:*:*:*
Original advisory text
the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS. A malicious user can send a evil request to cause the web framework crash.
the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS. A malicious user can send a evil request to cause the web framework crash.
Fix within
Internet-facing 14 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.5 High
Exploitation
2% chance of attack within 30 days
Type
CWE-20Improper Input Validation
Timeline
Published17 Jul 2017
Updated29 Oct 2026
First seen6 Mar 2026
Sources
Track software like this
Free during beta