Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
8.1

CVE-2017-0902: RubyGems: DNS hijacking can install malicious gems

CVE-2017-0902 · published 9 years ago
Summary

An attacker can trick RubyGems into downloading and installing fake gems from a server they control. This can happen if you're using an outdated version of RubyGems. Update to the latest version to protect your system.

What to do
  • Update jim weirich rubygems-update to version 2.6.13.
  • Update canonical ruby2.0 to version 2.0.0.484-1ubuntu2.10.
  • Update canonical ruby2.3 to version 2.3.1-2~16.04.6.
Affected software
Ecosystem VendorProductAffected versions
rubygems jim weirich rubygems-update < 2.6.13
Fix: upgrade to 2.6.13
– rubygems rubygems <= 2.6.12
cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:*
– debian debian_linux 8.0
9.0
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
– canonical ubuntu_linux 14.04
16.04
17.10
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
– redhat enterprise_linux_desktop 7.0
cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
– redhat enterprise_linux_server 7.0
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
– redhat enterprise_linux_server_aus 7.4
7.6
cpe:2.3:o:redhat:enterprise_linux_server_aus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_server_eus 7.4
7.5
7.6
cpe:2.3:o:redhat:enterprise_linux_server_eus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_server_tus 7.4
7.6
cpe:2.3:o:redhat:enterprise_linux_server_tus:7.4:*:*:*:*:*:*:*
– redhat enterprise_linux_workstation 7.0
cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*
Ubuntu:14.04:LTS canonical ruby2.0 < 2.0.0.484-1ubuntu2.10
Fix: upgrade to 2.0.0.484-1ubuntu2.10
Ubuntu:Pro:14.04:LTS canonical jruby All versions
Ubuntu:16.04:LTS canonical ruby2.3 < 2.3.1-2~16.04.6
Fix: upgrade to 2.3.1-2~16.04.6
Original advisory text
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attac...
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
References
Fix within
Internet-facing 3 days
Internal 60 days
  • Not known to be exploited
  • Can be exploited automatically (estimated)
  • Gives an attacker full control (estimated)
Severity
8.1 High
Exploitation
5% chance of attack within 30 days
Type
CWE-346Origin Validation Error
CWE-350Reliance on Reverse DNS Resolution for a Security-Critical Action
Timeline
Published31 Aug 2017
Updated25 Oct 2026
First seen6 Mar 2026
Track software like this
Free during beta