Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
8.8
CVE-2016-9577: SPICE server may crash or run malicious code
CVE-2016-9577 · published 8 years ago
Summary
The SPICE remote desktop service (versions before 0.13.90) can be tricked by a logged‑in user into processing specially crafted messages that overflow memory. This can cause the server to stop working or execute unwanted commands. Apply the latest update from your Linux distribution or vendor to fix the issue.
What to do
- Update spice to version 0.12.8-r3.
- Update debian spice to version 0.12.8-2.1.
- Update spice_project spice to version 0.13.90 or later.
Affected software
| Ecosystem | Vendor | Product | Affected versions |
|---|---|---|---|
| Alpine:v3.10 | – | spice |
< 0.12.8-r3 Fix: upgrade to 0.12.8-r3
|
| Debian:12 | debian | spice |
< 0.12.8-2.1 Fix: upgrade to 0.12.8-2.1
|
| Debian:13 | debian | spice |
< 0.12.8-2.1 Fix: upgrade to 0.12.8-2.1
|
| Debian:14 | debian | spice |
< 0.12.8-2.1 Fix: upgrade to 0.12.8-2.1
|
| – | spice_project | spice |
< 0.13.90 cpe:2.3:a:spice_project:spice:*:*:*:*:*:*:*:* |
| – | debian | debian_linux |
8.0 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_desktop |
6.0 7.0 cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_server |
6.0 7.0 cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_server_aus |
7.3 7.4 cpe:2.3:o:redhat:enterprise_linux_server_aus:7.3:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_server_eus |
7.3 7.4 7.5 cpe:2.3:o:redhat:enterprise_linux_server_eus:7.3:*:*:*:*:*:*:* |
| – | redhat | enterprise_linux_workstation |
6.0 7.0 cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* |
Original advisory text
A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading t...
A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.
References
- https://security-tracker.debian.org/tracker/CVE-2016-9577 Vendor Advisory
- https://security.alpinelinux.org/vuln/CVE-2016-9577 Vendor Advisory
- http://rhn.redhat.com/errata/RHSA-2017-0253.html Third Party Advisory
- http://rhn.redhat.com/errata/RHSA-2017-0549.html Third Party Advisory
- http://www.securityfocus.com/bid/96040 Third Party Advisory VDB Entry
- https://access.redhat.com/errata/RHSA-2017:0254 Third Party Advisory
- https://access.redhat.com/errata/RHSA-2017:0552 Third Party Advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2016-9577 Issue Tracking Third Party Advisory
- https://www.debian.org/security/2017/dsa-3790 Third Party Advisory
Severity
8.8
High
Type
CWE-20Improper Input Validation
CWE-122Heap-based Buffer Overflow
CWE-119Buffer Overflow
Timeline
Published27 Jul 2018
Updated30 Oct 2026
First seen22 Sep 2026
Track software like this
Free during beta