Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.5

CVE-2016-9445: gst-plugins-bad1.0 crash from oversized video dimensions

CVE-2016-9445 · published 9 years ago
Summary

The Debian gst-plugins-bad1.0 package can be forced to stop working if it receives video data with extremely large width or height values. This can cause the software to crash, interrupting any services that rely on it. Apply the latest security update or patch provided by Debian to avoid the issue.

What to do
  • Update debian gst-plugins-bad1.0 to version 1.10.1-1.
Affected software
Ecosystem VendorProductAffected versions
Debian:12 debian gst-plugins-bad1.0 < 1.10.1-1
Fix: upgrade to 1.10.1-1
Debian:13 debian gst-plugins-bad1.0 < 1.10.1-1
Fix: upgrade to 1.10.1-1
Debian:14 debian gst-plugins-bad1.0 < 1.10.1-1
Fix: upgrade to 1.10.1-1
– gstreamer gstreamer 1.10.0
cpe:2.3:a:gstreamer:gstreamer:1.10.0:*:*:*:*:*:*:*
Original advisory text
Integer overflow in the vmnc decoder in the gstreamer allows remote attackers to cause a denial of service (crash) via large width and height values, which triggers a buffer overflow.
Integer overflow in the vmnc decoder in the gstreamer allows remote attackers to cause a denial of service (crash) via large width and height values, which triggers a buffer overflow.
Severity
7.5 High
Exploitation
5% chance of attack within 30 days
Type
CWE-190Integer Overflow
Timeline
Published23 Jan 2017
Updated4 Nov 2026
First seen22 Sep 2026
Sources
CVE-2016-9445 · NVD
Track software like this
Free during beta