Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
7.4

CVE-2016-9417: MyBB before 1.8.8 lets attackers trick server into remote calls

CVE-2016-9417 · published 9 years ago
Summary

The MyBB forum software and its Merge System, versions older than 1.8.8, can be made to send requests to other sites on your behalf. This could let a malicious user make the server access internal resources or services you did not intend. Upgrade MyBB and the Merge System to version 1.8.8 or later, and consider restricting outbound traffic from the web server as an extra precaution.

What to do

The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.

Affected software
VendorProductAffected versions
mybb merge_system <= 1.8.7
cpe:2.3:a:mybb:merge_system:*:*:*:*:*:*:*:*
mybb mybb <= 1.8.7
cpe:2.3:a:mybb:mybb:*:*:*:*:*:*:*:*
Original advisory text
The fetch_remote_file function in MyBB (aka MyBulletinBoard) before 1.8.8 and MyBB Merge System before 1.8.8 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspec...
The fetch_remote_file function in MyBB (aka MyBulletinBoard) before 1.8.8 and MyBB Merge System before 1.8.8 allows remote attackers to conduct server-side request forgery (SSRF) attacks via unspecified vectors.
References
Fix within
Internet-facing 60 days
Internal At next upgrade
  • Not known to be exploited
  • Needs hands-on effort to exploit (estimated)
  • Gives an attacker partial control (estimated)
Severity
7.4 High
Exploitation
2% chance of attack within 30 days
Type
CWE-918Server-Side Request Forgery (SSRF)
Timeline
Published31 Jan 2017
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2016-9417 · NVD
Track software like this
Free during beta