Track vulnerabilities like this one.
Sign up free to get alerted when software you use is affected.
7.8
CVE-2016-7617: macOS Bluetooth before 10.12.2 can run malicious code
CVE-2016-7617 · published 9 years ago
Summary
Versions of macOS earlier than 10.12.2 have a flaw in the Bluetooth system that could let a specially crafted app run code with high privileges or crash the computer. This could allow an attacker to take control of the machine or cause it to stop working. Upgrade macOS to version 10.12.2 or later, or apply Apple’s security update, to close the risk.
What to do
The CVE record does not list a fixed version. Check the vendor's site or the advisory links below - a fix may already be released.
Affected software
| Vendor | Product | Affected versions |
|---|---|---|
| apple | mac_os_x |
<= 10.12.1 cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* |
Original advisory text
An issue was discovered in certain Apple products. macOS before 10.12.2 is affected. The issue involves the "Bluetooth" component. It allows attackers to execute arbitrary code in a privileged cont...
An issue was discovered in certain Apple products. macOS before 10.12.2 is affected. The issue involves the "Bluetooth" component. It allows attackers to execute arbitrary code in a privileged context or cause a denial of service (type confusion) via a crafted app.
Internet-facing
14 days
Internal
At next upgrade
- Not known to be exploited
- Needs hands-on effort to exploit (estimated)
- Gives an attacker full control (estimated)
Type
CWE-704Incorrect Type Conversion or Cast
Timeline
Published20 Feb 2017
Updated3 Nov 2026
First seen29 Sep 2026
Sources
CVE-2016-7617 · NVD
Track software like this
Free during beta