Track vulnerabilities like this one. Sign up free to get alerted when software you use is affected.
9.8

CVE-2016-6303: OpenSSL versions before 1.1.0 may crash from crafted input

CVE-2016-6303 · published 10 years ago
Summary

The cryptographic library OpenSSL (versions older than 1.1.0) can mishandle certain data, causing a counting error that writes outside its memory space. This can make the program stop working or become unstable when an attacker sends specially crafted information. Upgrade OpenSSL to version 1.1.0 or later, or apply the vendor’s security patch, to prevent the issue.

What to do
  • Update openssl to version 1.0.2h-r3.
  • Update debian openssl to version 1.0.2i-1.
Affected software
Ecosystem VendorProductAffected versions
Alpine:v3.2 – openssl < 1.0.2h-r3
Fix: upgrade to 1.0.2h-r3
Debian:12 debian openssl < 1.0.2i-1
Fix: upgrade to 1.0.2i-1
Debian:13 debian openssl < 1.0.2i-1
Fix: upgrade to 1.0.2i-1
Debian:14 debian openssl < 1.0.2i-1
Fix: upgrade to 1.0.2i-1
– nodejs node.js < 0.12.16
>= 4.0.0, < 4.6.0
>= 6.0.0, < 6.6.0
cpe:2.3:a:nodejs:node.js:*:*:*:*:*:*:*:*
– openssl openssl 1.0.1
1.0.1a
1.0.1b
1.0.1c
1.0.1d
1.0.1e
1.0.1f
1.0.1g
1.0.1h
1.0.1i
1.0.1j
1.0.1k
18 more version ranges
cpe:2.3:a:openssl:openssl:1.0.1:*:*:*:*:*:*:*
Original advisory text
Integer overflow in the MDC2_Update function in crypto/mdc2/mdc2dgst.c in OpenSSL before 1.1.0 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or po...
Integer overflow in the MDC2_Update function in crypto/mdc2/mdc2dgst.c in OpenSSL before 1.1.0 allows remote attackers to cause a denial of service (out-of-bounds write and application crash) or possibly have unspecified other impact via unknown vectors.
References
Severity
9.8 Critical
Exploitation
32% chance of attack within 30 days
Type
CWE-787Out-of-bounds Write
Timeline
Published16 Sep 2016
Updated29 Sep 2026
First seen22 Sep 2026
Sources
CVE-2016-6303 · NVD
Track software like this
Free during beta